Ideas & Suggestions for Barracuda MSP

Support FIPS 140-2 Certified Encryption

FIPS 140-2 certified encryption is required for US Goverment data, especially military data. It's required by CJIS requirements for any law enforcement data. And it's being required more by health care providers for any medical records. We've also had retail customers tell us they are requiring it to meet PCI requirements.

Please think about using FIPS 140-2 certified encryption for both the storage and transmission of backups. There are FIPS 140-2 certified libraries which are directly compatible with other standard encryption libraries - it takes the same input and generates the same output.

  • Guest
  • Mar 12 2020
  • Attach files